Back to overview
Downtime

Cloudflare Global Outage – app.sleak.ai currently unavailable

May 21, 2026 at 2:05pm UTC
Affected services
Application

Resolved
May 21, 2026 at 2:36pm UTC

Service fully restored

The Cloudflare outage has been resolved. The Sleak web application at app.sleak.ai is now fully operational again and accessible to all users.

All services are back to normal. No further action is required on your end.

We apologize for any disruption this may have caused. The outage was the result of a global Cloudflare infrastructure incident outside of our control. Thank you for your patience and understanding.

If you continue to experience any issues, please don't hesitate to reach out to our support team.

Created
May 21, 2026 at 2:05pm UTC

We are currently experiencing a full service outage affecting the Sleak web application at app.sleak.ai. The root cause is an ongoing infrastructure incident on Cloudflare's network (Error 522 – Connection Timed Out), which is impacting a large number of websites and applications globally that rely on Cloudflare's infrastructure.

What is happening?

Cloudflare is unable to establish a TCP connection to our origin server. This is not caused by an issue within Sleak's own infrastructure – it is a result of a global Cloudflare outage that is beyond our control.

What is affected?

The Sleak web application (app.sleak.ai) is currently unavailable
The Sleak homepage may also be intermittently unreachable
What are we doing?
We are actively monitoring Cloudflare's incident status and will restore full service as soon as Cloudflare resolves the underlying network issue. No action is required on your end.

ETA

Resolution depends entirely on Cloudflare. We will publish an update as soon as service is restored.

We sincerely apologize for the inconvenience and appreciate your patience.